$re = '/([A-Z]{2} \d{3,6})(\.\d*)?( [A-Z]\d+)+([\.\d\-\(\)\+]*)?/m';
$str = 'GL 5864 H598 M8-2+3
ZN 2455 B927(5.0)
LI 21900 H592
LH 42800.2004 H7
LI 99999 T454 Thomas
KI 5234 D65.2002
CB 3700 N664(3)
UQ 1000 B726 K9(7)E(3)
FH 15900 V878-2(3)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);