#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(dc|dcterms)\.title(?!\.alternative).*$"
Local $sString = "dc.title" & @CRLF & _
"dc.title[en_US]" & @CRLF & _
"dc.title[]" & @CRLF & _
"dc.title.alternative" & @CRLF & _
"dcterms.title" & @CRLF & _
"dcterms.title[en_US]" & @CRLF & _
"dcterms.title[]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")