const regex = /^(dc|dcterms)\.title(?!\.alternative).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(dc|dcterms)\\.title(?!\\.alternative).*$', 'gm')
const str = `dc.title
dc.title[en_US]
dc.title[]
dc.title.alternative
dcterms.title
dcterms.title[en_US]
dcterms.title[]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}