$re = '/[a-zA-Z][a-zA-Z0-9-.]+@[a-zA-Z-]+\.(com|edu|net)/m';
$str = '\'2abcdefghijklmnopqrcdtuvxyz\'
\'ABCDEFGHIJKLMNOPQRSTUVXYZ\'
\'0123456789\'
\'0988184106\', \'0911184106\'
\'0222573153\'
\'02 2257 3153\'
2/June/2018
3:24:23.45
leeyuyi1950@gmail.com
Mr. Schafer
Mr Smith
Ms David
Mrs. Robison
Mr. T
Leeyuyi@yahoo.com
mss.friend123@google.net
wang-321n-wu@kuo-university.edu
word /dboundaries odd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);