# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[a-zA-Z][a-zA-Z0-9-.]+@[a-zA-Z-]+\.(com|edu|net)"
test_str = ("'2abcdefghijklmnopqrcdtuvxyz'\n"
"'ABCDEFGHIJKLMNOPQRSTUVXYZ'\n"
"'0123456789'\n\n"
"'0988184106', '0911184106'\n\n"
"'0222573153'\n"
"'02 2257 3153'\n"
"2/June/2018\n"
"3:24:23.45\n\n"
"leeyuyi1950@gmail.com\n\n"
"Mr. Schafer\n"
"Mr Smith\n"
"Ms David\n"
"Mrs. Robison\n"
"Mr. T\n"
" \n"
"Leeyuyi@yahoo.com\n"
"mss.friend123@google.net\n"
"wang-321n-wu@kuo-university.edu\n\n"
"word /dboundaries odd\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.