package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(.*?)\]\s\((http.*?)\)`)
var str = `'[катетер-направленному тромболизису] (https://www.radiologyinfo.org/en/info.cfm?pg=thrombo), но та, которая, помимо удаления тромбов, также открывает и усиливает слишком маленькие кровеносные сосуды через стенты или другие средства. Также может быть желательно увеличить их проницаемость, чтобы фиксаторы достигали паренхимы мозга по всему кровеносному сосуду, а не только на кончиках. Лазер может делать микроскопические дыры по всей длине, а затем, возможно, добавить [тонкий слой полиамида] (https://en.wikipedia.org/wiki/Thin-film_composite_membrane#Structure_and_materials)'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}