Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?<=\s)(\d+)\s(st(u?)k?)s?|(p((ie)?ce(s?)))
/
g
Input 1
1
New
apple 10m 10mm 11ml 11kg 12g 13gr 14m3 15m2 apple 10 stuks 10 pieces 11 pces 11 pce 12 stk 13 stuks 14m3 15m2