re = /(^ktm-(?:.*-abcd)(?:-(?:e-|[^e]|e[^d].)*)(?:-[a-z]+).*|^abcd(?:-(?:e-|[^e]|e[^d].)*)(?:-[a-z]+).*)/m
str = 'ktm-ewe-abcd-st-ed-qrew
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end