Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"""
("|')((?!(?!\\)(\1|\n))|(\\(.|\n))|((?!\\).))*?(\1)
"""
g
Input 1
1
New
"valid line" 'valid line 2' '' "" "'''" "''''" '"""' '""""' "hello new line\ hello another line\ end blank line" 'hello blank line\ \ \\g\ end blank line' "\'" "\"" "errors" "broken line " 'broken line ' "broken line 2 \ffd \hellod " '\' "\" """ '''
Substitution
newstr
"valid line" 'valid line 2' '' "" "'''" "''''" '"""' '""""' "hello new line\ hello another line\ end blank line" 'hello blank line\ \ \\g\ end blank line' "\'" "\"" "errors" "broken line " 'broken line ' "broken line 2 \ffd \hellod " '\' "\" """ '''