// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^a-zA-Z][a-zA-Z]{1,2}$").unwrap();
let string = "ny12345d
ny12345dc
ny12346T01
ny12346dfA
ny12345";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}