package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<type>\w*)\/(?<subtype>[\w\.-]*)(?:\+(?<subtype>[\w\.-]*))?(?:;(?:(?<key>.+)=(?<value>.*);)*(?<key>.+)=(?<value>.*))?`)
var str = `application/svg+xml`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}