$re = '/(?<type>\w*)\/(?<subtype>[\w\.-]*)(?:\+(?<subtype>[\w\.-]*))?(?:;(?:(?<key>.+)=(?<value>.*);)*(?<key>.+)=(?<value>.*))?/';
$str = 'application/svg+xml';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);