use strict;
my $str = '
This guy makes my world turn and is my hero. He\'s #rescued. me from some of my darkest days and has been my champion through my struggles with combat related PTSD. I love you the mosterest, D1. 💚 #thankyouburger #dsdsfgd #sdfsdf #sdsfdfs, #sdffs';
my $regex = qr/(#(?!thankyouburger)[\w]+)/p;
my $subst = '($1)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";