using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"mi nombre es (?<name>[\w\W]+?) y mi correo es (?<email>[\w\W]+?) y quiero un cupo";
string input = @"Hola, mi nombre es Carlos y mi correo es carlos@carlos.com y quiero un cupo
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}