package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`mi nombre es (?<name>[\w\W]+?) y mi correo es (?<email>[\w\W]+?) y quiero un cupo`)
var str = `Hola, mi nombre es Carlos y mi correo es carlos@carlos.com y quiero un cupo
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}