const regex = /mi nombre es (?<name>[\w\W]+?) y mi correo es (?<email>[\w\W]+?) y quiero un cupo/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('mi nombre es (?<name>[\\w\\W]+?) y mi correo es (?<email>[\\w\\W]+?) y quiero un cupo', '')
const str = `Hola, mi nombre es Carlos y mi correo es carlos@carlos.com y quiero un cupo
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}