using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\w:\s?)([^:]+)\s(\w:\s?)([^:]+)(\s|$))";
string input = @"p: perguntaA r: respostaA p: perguntaB r: respostaB p: perguntaC r: respostaC";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}