$re = '/((\w:\s?)([^:]+)\s(\w:\s?)([^:]+)(\s|$))/';
$str = 'p: perguntaA r: respostaA p: perguntaB r: respostaB p: perguntaC r: respostaC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);