#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi){{%(cellbg\s*.+?)\s*}}"
Local $sString = "sometext.here{{%cellbg key.value }}some.other.text.i.don't.care.about"
Local $sSubst = "{% \1 %}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)