import Foundation
let pattern = #"{{%(cellbg\s*.+?)\s*}}"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"sometext.here{{%cellbg key.value }}some.other.text.i.don't.care.about"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{% \1 %}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)