// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:ABC_|CDE_|^)+(\S*?)(?:_DEF|$)").unwrap();
let string = "ABC_ANY_STRING_DEF
ANY_STRING
ANY_STRING_DEF
ABC_CDE_ANY_STRING_DEF";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}