use strict;
my $str = '0.0
1.230
00123
012.30400
0102
';
my $regex = qr/^0*(\d+(?:\.(?:(?!0+$)\d)+)?).*$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";