# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^0+?(\d{2})/$1/gm;t' <<< "001 - Filename 001.mp3
009 - Filename 009.mp3
010 - Filename 010.mp3
060 - Filename 060.mp3
086 - Filename 086.mp3
100 - Filename 100.mp3
1000 - Filename 1000.mp3
01001 - Filename 1001.mp3
01 - Filename with two leading numbers.mp3
1 - Filename with one leading number.mp3"