import Foundation
let pattern = #"^0+?(\d{2})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
001 - Filename 001.mp3
009 - Filename 009.mp3
010 - Filename 010.mp3
060 - Filename 060.mp3
086 - Filename 086.mp3
100 - Filename 100.mp3
1000 - Filename 1000.mp3
01001 - Filename 1001.mp3
01 - Filename with two leading numbers.mp3
1 - Filename with one leading number.mp3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)