# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w*)@((\w*\|\w*#{0,1})*)//g;t' <<< "foo01@chave1|valor1#chave2|valor2#chave3|valor3#chaveN|valorN"