#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\w*)@((\w*\|\w*#{0,1})*)"
Local $sString = "foo01@chave1|valor1#chave2|valor2#chave3|valor3#chaveN|valorN"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)