using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w*)@((\w*\|\w*#{0,1})*)";
string substitution = @"";
string input = @"foo01@chave1|valor1#chave2|valor2#chave3|valor3#chaveN|valorN";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}