// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\w*)@((\w*\|\w*#{0,1})*)").unwrap();
let string = "foo01@chave1|valor1#chave2|valor2#chave3|valor3#chaveN|valorN";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}