#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)## \(#.*?\)"
Local $sString = "## (#compact)`_.compact(array)`" & @CRLF & _
"" & @CRLF & _
"## (#concat)`_.concat(array, [values])`"
Local $sSubst = "## \{#.*?\}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)