#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)\D+"
Local $sString = "\n" & @CRLF & _
" \t\n" & @CRLF & _
" \n" & @CRLF & _
" 4 290 €\n" & @CRLF & _
" \n" & @CRLF & _
" \n" & @CRLF & _
" \n" & @CRLF & _
" \n"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)