package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\D+`)
var str = `\n
\t\n
\n
4 290 €\n
\n
\n
\n
\n`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}