#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<![\w/])/?r/[\dA-Za-z]\w{1,20}/?(?![\w/+])"
Local $sString = "Probando a detectar nombres de subreddits como" & @CRLF & _
"r/shortcuts y /r/3Dprinting, con barras delante" & @CRLF & _
"y detrás opcionales, como r/Marvel/ o /r/MCU/" & @CRLF & _
"" & @CRLF & _
"Pero no debería capturar nada en:" & @CRLF & _
"- reddit.com/user/atnbueno" & @CRLF & _
"- reddit.com/r/Applesilicon/" & @CRLF & _
"- congreso.gob.ar/materialdeConsulta.php" & @CRLF & _
"- /r/SpainPolitics+AskSpain+Spain/ (feed personalizado, no subreddit)" & @CRLF & _
"- /usr/local/r/412/R.framework/Resources (ruta en un disco duro)" & @CRLF & _
"" & @CRLF & _
"Además los nombres tienen un par de restricciones:" & @CRLF & _
"- r/nombre_demasiado_largo (no pueden ser de más de 21 caracteres)" & @CRLF & _
"- r/_nombre_no_valido (no pueden empezar por “_”)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")