$re = '/(?<![\w/])/?r/[\dA-Za-z]\w{1,20}/?(?![\w/+])/';
$str = 'Probando a detectar nombres de subreddits como
r/shortcuts y /r/3Dprinting, con barras delante
y detrás opcionales, como r/Marvel/ o /r/MCU/
Pero no debería capturar nada en:
- reddit.com/user/atnbueno
- reddit.com/r/Applesilicon/
- congreso.gob.ar/materialdeConsulta.php
- /r/SpainPolitics+AskSpain+Spain/ (feed personalizado, no subreddit)
- /usr/local/r/412/R.framework/Resources (ruta en un disco duro)
Además los nombres tienen un par de restricciones:
- r/nombre_demasiado_largo (no pueden ser de más de 21 caracteres)
- r/_nombre_no_valido (no pueden empezar por “_”)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);