import Foundation
let pattern = #"(?<![\w/])/?r/[\dA-Za-z]\w{1,20}/?(?![\w/+])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Probando a detectar nombres de subreddits como
r/shortcuts y /r/3Dprinting, con barras delante
y detrás opcionales, como r/Marvel/ o /r/MCU/
Pero no debería capturar nada en:
- reddit.com/user/atnbueno
- reddit.com/r/Applesilicon/
- congreso.gob.ar/materialdeConsulta.php
- /r/SpainPolitics+AskSpain+Spain/ (feed personalizado, no subreddit)
- /usr/local/r/412/R.framework/Resources (ruta en un disco duro)
Además los nombres tienen un par de restricciones:
- r/nombre_demasiado_largo (no pueden ser de más de 21 caracteres)
- r/_nombre_no_valido (no pueden empezar por “_”)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)