# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/==(\w.*?)==/==<mark>$1<\/mark>==/gm;t' <<< "==this is a test==
here ==is another test== and yet ==some other test=="