use strict;
my $str = '==this is a test==
here ==is another test== and yet ==some other test==';
my $regex = qr/==(\w.*?)==/mp;
my $subst = '==<mark>$1</mark>==';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";