// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"RestApiUsernameToken Username="([^"@]+)", Domain="([^"@]+){0,1}", Digest="([^"]+)", Nonce="([^"]+)", Created="(\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}Z)""#).unwrap();
let string = "RestApiUsernameToken Username=\"admin\", Domain=\"default\", Digest=\"+PJg7Tb3v98XnL6iJVv+v5hwhYjdzQ2tIWxvJB2cE40=\", Nonce=\"bfb79078ff44c35714af28b7412a702b\", Created=\"2016-04-29T15:48:26Z\"";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}