#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)nodejs|(?i)starter-kit-nestjs|(?i)kafkaConsumerProducerBench"
Local $sString = "diagnostics-nodejs" & @CRLF & _
"documentdb-client-nodeJS" & @CRLF & _
"gherkin-runner-nodejs" & @CRLF & _
"openid-client-nodejs-useless" & @CRLF & _
"azure-blob-storage-client-nodejs" & @CRLF & _
"azure-sql-client-nodejs" & @CRLF & _
"CPNodeJS" & @CRLF & _
"appmon-oneagent-linux-nodejs-useless" & @CRLF & _
"kafkaConsumerProducerBench" & @CRLF & _
"sample-publish-kafka-nodeJS" & @CRLF & _
"starter-kit-nestjs"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")