using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)nodejs|(?i)starter-kit-nestjs|(?i)kafkaConsumerProducerBench";
string input = @"diagnostics-nodejs
documentdb-client-nodeJS
gherkin-runner-nodejs
openid-client-nodejs-useless
azure-blob-storage-client-nodejs
azure-sql-client-nodejs
CPNodeJS
appmon-oneagent-linux-nodejs-useless
kafkaConsumerProducerBench
sample-publish-kafka-nodeJS
starter-kit-nestjs";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}