import Foundation
let pattern = #"(?i)nodejs|(?i)starter-kit-nestjs|(?i)kafkaConsumerProducerBench"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
diagnostics-nodejs
documentdb-client-nodeJS
gherkin-runner-nodejs
openid-client-nodejs-useless
azure-blob-storage-client-nodejs
azure-sql-client-nodejs
CPNodeJS
appmon-oneagent-linux-nodejs-useless
kafkaConsumerProducerBench
sample-publish-kafka-nodeJS
starter-kit-nestjs
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)