const regex = new RegExp('(?<=\\")[\\w.]+(?=\\")', 'gmi')
const str = `results[0].items[0].packages[0].settings["compiler.version"]
results[0].items[0].packages[0].settings.build_type`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}