$re = '/(?<=Here).*(?=string)/m';
$str = 'Here is a string, and Here is another string.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);