using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"class\s+([A-Z]\w+)\s+(?:<\s+(\w+))?\s*{[\s\S]*?\n}";
string input = @"class Main < Console {
+ main:Int () {
!String hello = ""Hello, World!"";
this.out(hello);
>> 0;
}
}
class Foobar {
+ foobar:None () {
#Some code...
}
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}