using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<client>\w*)(?:-?(?<environment>\w*)?)\.(?<domain>[\w-]*\.\w*)\s*$";
string input = @"wd.commloanservices.net
wd.commloanservices.net
agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
bin.agamerica-qa.commloanservices.com
gf0.agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
agamerica.commloanservices.com
agamerica.commloanservices.com
agamerica.commloanservices.com
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}