$re = '/(?<client>\w*)(?:-?(?<environment>\w*)?)\.(?<domain>[\w-]*\.\w*)\s*$/m';
$str = 'wd.commloanservices.net
wd.commloanservices.net
agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
bin.agamerica-qa.commloanservices.com
gf0.agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
agamerica-qa.commloanservices.com
agamerica.commloanservices.com
agamerica.commloanservices.com
agamerica.commloanservices.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);