const regex = /(?:\G(?!\A)(?:[^\d\s]*200B)?|P:\h*)[^\d\s]*\K(?!200B)\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!\\A)(?:[^\\d\\s]*200B)?|P:\\h*)[^\\d\\s]*\\K(?!200B)\\d+', 'gm')
const str = `H: 290‐314 P: 280‐301+330U+200B+331string‐305+351+338‐308+310 [2]
Output: [280,301,330, 331, 305,351,338,308,310]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}