re = /(?:\G(?!\A)(?:[^\d\s]*200B)?|P:\h*)[^\d\s]*\K(?!200B)\d+/m
str = 'H: 290‐314 P: 280‐301+330U+200B+331string‐305+351+338‐308+310 [2]
Output: [280,301,330, 331, 305,351,338,308,310]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end