package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z]{3}-\d{4}|[A-Z]{3}\d[A-Z]\d{2}`)
var str = `ABC-1234, RTE5J78, XYZ-9876, WSD4K22`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}