package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{3,5}`)
var str = `1
123
123456
1237 Main Street,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}