$re = '/^(\p{Han}+)\P{Han}.*\1$/m';
$str = '测试1003##$%#测试
测试1003##$%#测
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);